Upcoming Browser Version Update for DejaClick Monitors – June 30, 2025

Incident Report for AlertSite

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 07:06 UTC

Monitoring

We have updated the default browser versions for DejaClick monitors.

The changes are as follows:
Chrome: from version 85 to version 120
Firefox: from version 78 to version 102

If you encounter any issues with your monitors that were previously functioning correctly, you can manually revert to a lower browser version: Chrome v85 or Firefox v78.

Thank you for your understanding.
Posted Jul 04, 2025 - 11:57 UTC

Investigating

Dear User,
We will be updating the default browser versions for DejaClick monitors on June 30, 2025. The changes are as follows:
Chrome: from version 85 to version 120
Firefox: from version 78 to version 102
If you encounter any issues with your monitors that were previously functioning correctly, you can manually revert to a lower browser version: Chrome v85 or Firefox v78.
Thank you for your understanding.
Posted Jun 19, 2025 - 14:31 UTC